Simstopia
Hello and Welcome to Simstopia! Feel free to create an account, but if you already have one, welcome back.

High quality grass WITHOUT Advanced Rendering--also reduces lag

Go down

High quality grass WITHOUT Advanced Rendering--also reduces lag

Post by brunettesimgirl on Mon Dec 31, 2012 9:37 pm

ONLY DO THIS IF YOU DO NOT HAVE PETS!!! YOU NEED TO HAVE A.R. CHECK-MARKED, IN-GAME, IN ORDER FOR YOUR PETS TO NOT BE "TRANSPARENT".





So this is a picture tutorial of Rockermonkey999's thread here: High quality grass WITHOUT Advanced Rendering.





This is really rather easy, but I decided to make a tutorial anyway for those that are unsure or having problems, and some do better with a visual. Smile





So lets get started.





The very first thing I want you to do is start up your Sims 3 game.





Then go to Options:





*note--click on the pictures to see the original size*





Under "Graphics" I want you to un-uncheck "Enable Advanced Rendering"





Click the checkmark to accept the change, and "quit and save (or save, then quit--however you do it)





Next I want you to go to start then "computer"





Go to where you have installed your game.  It is usually under program files, or program files (x86)





Electronic Arts

Sims 3


Game


Bin


Once you are in your "bin" folder you are going to look for a file called, "GraphicRules" it is an SGR File




Double click on it to open it.  If it asks you to choose a program to open it with, choose "Notepad".  One you have it open you should a lot of script writing, but don't let that freak you out.  We're only looking for one part.  What you want to look for is:
option AdvancedRendering
    setting $Off
   prop $ConfigGroup RenderForceMinspecShaders 1
prop $ConfigGroup TerrainLODMode 1
prop $ConfigGroup RenderPostProcessEnabled false
prop $ConfigGroup RenderShadowsEnabled false
prop $ConfigGroup CullUndergroundBuildBuyStructures 0


This is a little more than half way down as you can see from the pic below.   The highlighted part that reads, "

prop $ConfigGroup TerrainLODMode 1" is what we are going to change...and that is all we're changing.










But before we do any changing, what I want you to do is save this as it is.  Just click on "file" and "save as".  Name it something that you will remember and put it in a safe place. (example--I named my backup file "sims 3 graphic rules original".  You do this in case there is any problems, then you can just copy the backup and replace it with the one we're changing in the bin folder.
 Now that you've got the original file backed up in a safe place I want you to go to the "
prop $ConfigGroup TerrainLODMode 1" part and change that "1" to a "0", so now it will look like this:






option AdvancedRendering
    setting $Off
    prop $ConfigGroup RenderForceMinspecShaders 1
prop $ConfigGroup TerrainLODMode 0
prop $ConfigGroup RenderPostProcessEnabled false
prop $ConfigGroup RenderShadowsEnabled false
prop $ConfigGroup CullUndergroundBuildBuyStructures 0




Now that you have that changed, go to "file" and "Save".  It will ask you if you want to replace the original--click "yes".




Now--if you have other EP's, you need to do this with every single EP.  What we did above was for the base (which needs to be changed as well--but if you just followed this tutorial--you don't need to worry about doing the base because you just did it!)


So the steps for the EP's are the same.  However, if you can remember that the original file has a "1" instead of a "0" you do not NEED to make backups of all those EP files, but it's up to you if you want to do it (just a suggestion if you do it--make sure you save the backup file according to EP.  Example: Sims3 Generations GameRules Original; sims3 Late Night GameRules Original etc.


Now a IMPORTANT note:  Each EP you add you need to do this to that new EP, and while you are doing that, check the base game file to make sure that it didn't bounce back to a "1"...if it does, just change that "1" back to a "0" and save, overwrite? Yes. As with the new EP's added, you may notice that a update from the site/Origin may also bounce the "0" back to a "1" in the base game file.  This has only happened to me twice.  The first time was with Generations (which was my last EP installed as of 11/21/2011) and with the Pets Update. Both bounced my base game file back to a "1", so I had to go into that file and change it back to a "0".  


If you are unsure if has bounced it back or not, just look to your game for the answer.  If it hasn't the grass will look like this on all the grass (I mean grass that is not on your lot): 


If the file has been bounced back then the grass shown above would look like it was painted in paint...it would look flat, like this:


(photo's courtesy of 


So if your grass looks like the above pics after an update AFTER you've successfully changed the file , then you just need to go through the files and check  to make sure the base game file and each EP file has the "0" and not the "1".  Once you find the culprit, change it, save it, and it should fix it.






You will also notice, from following this tutorial, that the game will run a bit smoother.  






Hope this helped!  Smile

*note--I have heard that there is an issue with Supernatural when doing this. When doing this with Supernatural, it turns the mountins/hills in the background black/dark brown. I have not been able to duplicate this with my game and using this technique. If I find a solution to that issue, I will post it here.
avatar
brunettesimgirl
Administrator
Administrator

Life of the Party August 2011 Life of the Party
Forum King or Queen July 2011 Forum Queen
Gender : Female
Posts : 2549
Join date : 2011-04-26
Location : Somewhere Only We Know

http://brunettesimgirlsimmies.blogspot.com/

Back to top Go down

Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum